summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Northover <tnorthover@apple.com>2014-05-24 12:50:23 +0000
committerTim Northover <tnorthover@apple.com>2014-05-24 12:50:23 +0000
commit29f94c72014eaa5d0d3b920686e689e79759cacb (patch)
treecb2e1cc50e9a80c55f33e15ec2ce110a6b05019a /CMakeLists.txt
parent9105f66d6f3cb6330ce77a88a0ef1ec0744aba85 (diff)
downloadllvm-29f94c72014eaa5d0d3b920686e689e79759cacb.tar.gz
llvm-29f94c72014eaa5d0d3b920686e689e79759cacb.tar.bz2
llvm-29f94c72014eaa5d0d3b920686e689e79759cacb.tar.xz
AArch64/ARM64: move ARM64 into AArch64's place
This commit starts with a "git mv ARM64 AArch64" and continues out from there, renaming the C++ classes, intrinsics, and other target-local objects for consistency. "ARM64" test directories are also moved, and tests that began their life in ARM64 use an arm64 triple, those from AArch64 use an aarch64 triple. Both should be equivalent though. This finishes the AArch64 merge, and everyone should feel free to continue committing as normal now. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@209577 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b19ab0271a..0d6eead42f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,7 +127,7 @@ set(LLVM_INCLUDE_DIR ${CMAKE_CURRENT_BINARY_DIR}/include)
set(LLVM_LIBDIR_SUFFIX "" CACHE STRING "Define suffix of library directory name (32/64)" )
set(LLVM_ALL_TARGETS
- ARM64
+ AArch64
ARM
CppBackend
Hexagon
@@ -143,7 +143,7 @@ set(LLVM_ALL_TARGETS
)
# List of targets with JIT support:
-set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM64 ARM Mips SystemZ)
+set(LLVM_TARGETS_WITH_JIT X86 PowerPC AArch64 ARM Mips SystemZ)
set(LLVM_TARGETS_TO_BUILD "all"
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")