summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-11-13 19:12:02 +0000
committerHans Wennborg <hans@hanshq.net>2013-11-13 19:12:02 +0000
commit4ac2e3c604f938ce3db5dc0af413e1010c1b99c9 (patch)
tree8c66b5e1b5da87e4781db932e385eaca532f42de /CMakeLists.txt
parent929bdb23794b615dc6b0cc59db21f0450c3ce33b (diff)
downloadllvm-4ac2e3c604f938ce3db5dc0af413e1010c1b99c9.tar.gz
llvm-4ac2e3c604f938ce3db5dc0af413e1010c1b99c9.tar.bz2
llvm-4ac2e3c604f938ce3db5dc0af413e1010c1b99c9.tar.xz
CMake: make building with /MT an option instead of always forcing it
for release builds. This is a follow-up to r194589. Aaron pointed out that building libraries with /MT and using them in an application that uses a different run-time library can be a bad idea. Move the option to build with /MT behind a CMake option so it can be turned on selectively, such as when building the toolchain installer. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@194596 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6fd506f78..5a8eb98027 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,8 @@ set(PACKAGE_VERSION "${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}svn")
option(LLVM_INSTALL_TOOLCHAIN_ONLY "Only include toolchain files in the 'install' target." OFF)
+option(LLVM_STATIC_MSVC_RUNTIME "When using MSVC, link against the static run-time (/MT)" OFF)
+
option(LLVM_USE_FOLDERS "Enable solution folders in Visual Studio. Disable for Express versions." ON)
if ( LLVM_USE_FOLDERS )
set_property(GLOBAL PROPERTY USE_FOLDERS ON)