summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-10-17 18:39:47 +0000
committerHans Wennborg <hans@hanshq.net>2013-10-17 18:39:47 +0000
commit4d1a9256752048f34c6091cc145fce9f89d20985 (patch)
tree1cb3d17019bb7210624535a58feaa4627e485575 /CMakeLists.txt
parentb75fcecb0ff2f22e79454ce9ed7c246792bdbf0d (diff)
downloadllvm-4d1a9256752048f34c6091cc145fce9f89d20985.tar.gz
llvm-4d1a9256752048f34c6091cc145fce9f89d20985.tar.bz2
llvm-4d1a9256752048f34c6091cc145fce9f89d20985.tar.xz
CMake: set stack size for MSVC in just one place
After r192904, Reid pointed out he thought we already set the stack size for MSVC. Turns out we did, but it didn't seem to work. This commit sets the stack size in a single place, using CMAKE_EXE_LINKER_FLAGS because that seems to be the way that works best. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@192912 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17ef03aaf9..f85b6cc363 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,15 +22,6 @@ if ( LLVM_USE_FOLDERS )
set_property(GLOBAL PROPERTY USE_FOLDERS ON)
endif()
-if(MSVC AND NOT (${CMAKE_VERSION} VERSION_LESS 2.8.11))
- # set stack reserved size to ~10MB
- # CMake previously automatically set this value for MSVC builds, but the
- # behavior was changed in CMake 2.8.11 (Issue 12437) to use the MSVC default
- # value (1 MB) which is not enough for us in tasks such as parsing recursive
- # C++ templates in Clang.
- set(CMAKE_CXX_STACK_SIZE "10000000")
-endif()
-
include(VersionFromVCS)
option(LLVM_APPEND_VC_REV