summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2014-01-13 22:21:34 +0000
committerChandler Carruth <chandlerc@gmail.com>2014-01-13 22:21:34 +0000
commit55e6c6184ae5c018fa8fc79a9b844557fa2a0787 (patch)
tree313d6a312182b357294cb4316c02be88b18d9d1b /CMakeLists.txt
parentd00ec5ef7bbb323c2a98a2a5028be2ccd093d24e (diff)
downloadllvm-55e6c6184ae5c018fa8fc79a9b844557fa2a0787.tar.gz
llvm-55e6c6184ae5c018fa8fc79a9b844557fa2a0787.tar.bz2
llvm-55e6c6184ae5c018fa8fc79a9b844557fa2a0787.tar.xz
Factor the option and checking of compiler version better. Put the
option with the others in the top level CMakeLists, and put the check in HandleLLVMOptions. This will also let it be used from the standalone Clang builds. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@199149 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06f4335f13..c689dca3b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,6 +195,9 @@ else()
option(LLVM_ENABLE_ASSERTIONS "Enable assertions" ON)
endif()
+option(LLVM_FORCE_USE_OLD_HOST_TOOLCHAIN
+ "Set to ON to force using an old, unsupported host toolchain." OFF)
+
option(LLVM_USE_INTEL_JITEVENTS
"Use Intel JIT API to inform Intel(R) VTune(TM) Amplifier XE 2011 about JIT code"
OFF)