summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-10-04 10:41:38 +0000
committerAlexey Samsonov <samsonov@google.com>2013-10-04 10:41:38 +0000
commit651c467130fbed3ec5624de011e3920545099d1d (patch)
tree105a1f754665d77d172d53acdb27c42eb44036df /CMakeLists.txt
parentdd518bcc9dd9e4028b2a979ced09edd5b6becd07 (diff)
downloadllvm-651c467130fbed3ec5624de011e3920545099d1d.tar.gz
llvm-651c467130fbed3ec5624de011e3920545099d1d.tar.bz2
llvm-651c467130fbed3ec5624de011e3920545099d1d.tar.xz
Restore LLVM_BUILD_RUNTIME option that was deleted in r191835, but is still used to control building of compiler-rt and libcxx
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@191948 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4ec094f1b..17ef03aaf9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -253,6 +253,8 @@ option(LLVM_INCLUDE_TOOLS "Generate build targets for the LLVM tools." ON)
option(LLVM_BUILD_TOOLS
"Build the LLVM tools. If OFF, just generate build targets." ON)
+option(LLVM_BUILD_RUNTIME
+ "Build the LLVM runtime libraries." ON)
option(LLVM_BUILD_EXAMPLES
"Build the LLVM example programs. If OFF, just generate build targets." OFF)
option(LLVM_INCLUDE_EXAMPLES "Generate build targets for the LLVM examples" ON)