summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Christopher <echristo@gmail.com>2013-07-30 21:44:10 +0000
committerEric Christopher <echristo@gmail.com>2013-07-30 21:44:10 +0000
commit6aebd5facbbc80787270cc1b18bffbf6c6f655e8 (patch)
tree393014f86e53c4499bbf0c7e5828e56d48edfc29 /CMakeLists.txt
parent0de6832c16ce48f6546c74f6b17e27d149eebfb2 (diff)
downloadllvm-6aebd5facbbc80787270cc1b18bffbf6c6f655e8.tar.gz
llvm-6aebd5facbbc80787270cc1b18bffbf6c6f655e8.tar.bz2
llvm-6aebd5facbbc80787270cc1b18bffbf6c6f655e8.tar.xz
Add capability for building with -gsplit-dwarf to the cmake build.
In limited testing this seems to work. Caveat emptor. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@187452 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7697a2b9c5..687176ca57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,6 +183,9 @@ endif( LLVM_USE_OPROFILE )
set(LLVM_USE_SANITIZER "" CACHE STRING
"Define the sanitizer used to build binaries and tests.")
+option(LLVM_USE_SPLIT_DWARF
+ "Use -gsplit-dwarf when compiling llvm." OFF)
+
# Define an option controlling whether we should build for 32-bit on 64-bit
# platforms, where supported.
if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )