summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUlrich Weigand <ulrich.weigand@de.ibm.com>2013-05-06 16:22:34 +0000
committerUlrich Weigand <ulrich.weigand@de.ibm.com>2013-05-06 16:22:34 +0000
commit735ab83b3cbe18c97ec9e397c41fa21a7ef639a4 (patch)
tree770b6c385fadf8631f1e51582ee1433b01e61691 /CMakeLists.txt
parent7207285e65730c0ce488ca2ddf86dee27d66e57a (diff)
downloadllvm-735ab83b3cbe18c97ec9e397c41fa21a7ef639a4.tar.gz
llvm-735ab83b3cbe18c97ec9e397c41fa21a7ef639a4.tar.bz2
llvm-735ab83b3cbe18c97ec9e397c41fa21a7ef639a4.tar.xz
[SystemZ] Add configure bits
This patch wires up the SystemZ target in configure, so that it can now be built using --enable-targets=systemz. It is not yet included in the default build (--enable-targets=all); this will be done by a follow-up patch. Patch by Richard Sandiford. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@181208 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d15a54b9e7..77b3436657 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,7 +89,7 @@ set(LLVM_ALL_TARGETS
)
# List of targets with JIT support:
-set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM Mips)
+set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM Mips SystemZ)
set(LLVM_TARGETS_TO_BUILD "all"
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")