summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-06-06 06:39:00 +0000
committerAlp Toker <alp@nuanti.com>2014-06-06 06:39:00 +0000
commit7a0e6972ce2e43fc006acd87a0f7b9cc5eb136bf (patch)
tree8b69c0e7cbeb56cfd4b3bd2b7db52cbb5e18d268 /CMakeLists.txt
parentb73a9b384e3fd73fe8739310b1fc7aa52ab9c9ae (diff)
downloadllvm-7a0e6972ce2e43fc006acd87a0f7b9cc5eb136bf.tar.gz
llvm-7a0e6972ce2e43fc006acd87a0f7b9cc5eb136bf.tar.bz2
llvm-7a0e6972ce2e43fc006acd87a0f7b9cc5eb136bf.tar.xz
Make LINK_POLLY_INTO_TOOLS work with the CMake build
The option check was being performed after config.h/llvm-config.h substitution, generating incorrect macro definitions. Fixes PR19614. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@210311 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d6eead42f..91695746f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -244,6 +244,9 @@ set(LLVM_USE_SANITIZER "" CACHE STRING
option(LLVM_USE_SPLIT_DWARF
"Use -gsplit-dwarf when compiling llvm." OFF)
+option(WITH_POLLY "Build LLVM with Polly" ON)
+option(LINK_POLLY_INTO_TOOLS "Static link Polly into tools" OFF)
+
# Define an option controlling whether we should build for 32-bit on 64-bit
# platforms, where supported.
if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
@@ -515,9 +518,6 @@ endif()
add_subdirectory(projects)
-option(WITH_POLLY "Build LLVM with Polly" ON)
-option(LINK_POLLY_INTO_TOOLS "Static link Polly into tools" OFF)
-
if(WITH_POLLY)
if(NOT EXISTS ${LLVM_MAIN_SRC_DIR}/tools/polly/CMakeLists.txt)
set(WITH_POLLY OFF)