summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArnaud A. de Grandmaison <arnaud.adegm@gmail.com>2013-11-26 10:33:53 +0000
committerArnaud A. de Grandmaison <arnaud.adegm@gmail.com>2013-11-26 10:33:53 +0000
commit7c6be4d5586aa365c8f52289ffddf57b87da4da7 (patch)
tree0dae14f58d3b58b042346026104e90ada4187c6f /CMakeLists.txt
parent54fec07ec00b4449393a66e8e2e62fd241781f80 (diff)
downloadllvm-7c6be4d5586aa365c8f52289ffddf57b87da4da7.tar.gz
llvm-7c6be4d5586aa365c8f52289ffddf57b87da4da7.tar.bz2
llvm-7c6be4d5586aa365c8f52289ffddf57b87da4da7.tar.xz
CMake : optionaly enable LLVM to be compiled with -std=c++11 (default: off)
In some case, it may be required to build LLVM in C++11 mode, as some the subprojects (like lldb) requires it. This mimics the autoconf behaviour. However, given the discussions on the switch to C++11 of the codebase, this behaviour should evolve to default to C++11 with some checks of the compiler capabilities. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@195727 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 551b17828b..ce952f8997 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,7 @@ else( MSVC )
option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." ON)
endif()
+option(LLVM_ENABLE_CXX11 "Compile with C++11 enabled." OFF)
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)