summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-27 08:59:01 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-27 08:59:01 +0000
commit9e443ca92a2b2dc89b3dea9a67bb8ab205e25777 (patch)
tree6d362e55ae63842a4ee037ea7c1e080ccd26fd11 /CMakeLists.txt
parent1348dc097d65dd3eb59046c933496cc7bc72e556 (diff)
downloadllvm-9e443ca92a2b2dc89b3dea9a67bb8ab205e25777.tar.gz
llvm-9e443ca92a2b2dc89b3dea9a67bb8ab205e25777.tar.bz2
llvm-9e443ca92a2b2dc89b3dea9a67bb8ab205e25777.tar.xz
[CMake] Introduce LLVM_BUILD_EXTERNAL_COMPILER_RT option
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202363 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c16afaeb5..72901c8876 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,6 +287,9 @@ option (LLVM_BUILD_DOCS "Build the llvm documentation." OFF)
option (LLVM_INCLUDE_DOCS "Generate build targets for llvm documentation." ON)
option (LLVM_ENABLE_DOXYGEN "Use doxygen to generate llvm documentation." OFF)
+option (LLVM_BUILD_EXTERNAL_COMPILER_RT
+ "Build compiler-rt as an external project." OFF)
+
# All options referred to from HandleLLVMOptions have to be specified
# BEFORE this include, otherwise options will not be correctly set on
# first cmake run