summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYaron Keren <yaron.keren@gmail.com>2014-03-04 09:23:33 +0000
committerYaron Keren <yaron.keren@gmail.com>2014-03-04 09:23:33 +0000
commitb62b44ccc5a6b147a41766bb39bc662fb0c589bd (patch)
treefc53df34fc8f3d5d1fc15f4a36bdc2657ae0dba9 /CMakeLists.txt
parent13f0d301e80d5bb43924d049ac7a3f853df20394 (diff)
downloadllvm-b62b44ccc5a6b147a41766bb39bc662fb0c589bd.tar.gz
llvm-b62b44ccc5a6b147a41766bb39bc662fb0c589bd.tar.bz2
llvm-b62b44ccc5a6b147a41766bb39bc662fb0c589bd.tar.xz
Cleaning up a bunch of pre-Visual C++ 2012 build hacks.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202806 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f513c558a..f3a09dd9f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -562,12 +562,3 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
)
endif()
-# Workaround for MSVS10 to avoid the Dialog Hell
-# FIXME: This could be removed with future version of CMake.
-if(MSVC_VERSION EQUAL 1600)
- set(LLVM_SLN_FILENAME "${CMAKE_CURRENT_BINARY_DIR}/LLVM.sln")
- if( EXISTS "${LLVM_SLN_FILENAME}" )
- file(APPEND "${LLVM_SLN_FILENAME}" "\n# This should be regenerated!\n")
- endif()
-endif()
-