summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Pop <spop@codeaurora.org>2014-03-14 04:04:14 +0000
committerSebastian Pop <spop@codeaurora.org>2014-03-14 04:04:14 +0000
commitbeaa95d97f319dc9b93b89850ab2ed9790182166 (patch)
tree75e0fc199ec98fa57d0fb06b200098b3568a0a29 /CMakeLists.txt
parent757ed6daf4c7720cddebdc3f502f7ecb110ded72 (diff)
downloadllvm-beaa95d97f319dc9b93b89850ab2ed9790182166.tar.gz
llvm-beaa95d97f319dc9b93b89850ab2ed9790182166.tar.bz2
llvm-beaa95d97f319dc9b93b89850ab2ed9790182166.tar.xz
static link polly into tools
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@203886 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49d1296950..237701818f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -503,6 +503,8 @@ endif()
add_subdirectory(projects)
option(WITH_POLLY "Build LLVM with Polly" ON)
+option(LINK_POLLY_INTO_TOOLS "Static link Polly into tools" OFF)
+
if(WITH_POLLY)
if(NOT EXISTS ${LLVM_MAIN_SRC_DIR}/tools/polly/CMakeLists.txt)
set(WITH_POLLY OFF)