summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2014-01-13 22:05:20 +0000
committerChandler Carruth <chandlerc@gmail.com>2014-01-13 22:05:20 +0000
commitd00ec5ef7bbb323c2a98a2a5028be2ccd093d24e (patch)
treea24ad5db5e05b1a7ee27ead0423bf5880fbf4615 /CMakeLists.txt
parent486fdf2e654c419f013d463abad4aef575b4c11b (diff)
downloadllvm-d00ec5ef7bbb323c2a98a2a5028be2ccd093d24e.tar.gz
llvm-d00ec5ef7bbb323c2a98a2a5028be2ccd093d24e.tar.bz2
llvm-d00ec5ef7bbb323c2a98a2a5028be2ccd093d24e.tar.xz
Raise the minimum CMake version to 2.8.8 -- we have a report that the
compiler version checking doesn't work on 2.8.7. This feature was documented in 2.8.10, but existed for an unknown amount of time before that. I'm actually happy to revert this and remove the use of the feature if there is anyone with a specific problem updating CMake. Please just let me know. I don't want to re-implement this CMake functionality unless there is a reason, and this is the only real way to find that out. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@199148 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 949abe1e6d..06f4335f13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
# See docs/CMake.html for instructions about how to build LLVM with CMake.
project(LLVM)
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 2.8.8)
# Add path for custom modules
set(CMAKE_MODULE_PATH