summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2014-02-22 12:36:28 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2014-02-22 12:36:28 +0000
commitea5f6769f61a100d176abcf26775372afa014517 (patch)
tree876633a1724f5a3731a6056b47cf362be6cfe969 /CMakeLists.txt
parent8c0eb3eee8d5f7894c9cfee6e6c4e5fb2d5c1c82 (diff)
downloadllvm-ea5f6769f61a100d176abcf26775372afa014517.tar.gz
llvm-ea5f6769f61a100d176abcf26775372afa014517.tar.bz2
llvm-ea5f6769f61a100d176abcf26775372afa014517.tar.xz
Revert "Use relative rpath so that the installation and build dirs are relocatable."
This reverts commit r201921. This should bring the polly bots back. I will try to build it locally to understand how cmake was setting the rpath of LLVMPolly.so. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@201934 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 21c64b0b92..cd8b363f7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -423,13 +423,9 @@ set( CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/bin )
set( CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
-set(CMAKE_BUILD_WITH_INSTALL_RPATH ON)
-if (APPLE)
- set(CMAKE_INSTALL_NAME_DIR "@rpath")
- set(CMAKE_INSTALL_RPATH "@executable_path/../lib")
-else(UNIX)
- set(CMAKE_INSTALL_RPATH "\$ORIGIN/../lib")
-endif()
+if( NOT DEFINED CMAKE_INSTALL_RPATH )
+ set( CMAKE_INSTALL_RPATH "\$ORIGIN/../lib")
+endif( NOT DEFINED CMAKE_INSTALL_RPATH )
set(CMAKE_INCLUDE_CURRENT_DIR ON)