summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-04-23 08:28:39 +0000
committerAlexey Samsonov <samsonov@google.com>2013-04-23 08:28:39 +0000
commitee03c949b85036b68c261dcc27dca064ee7e525d (patch)
tree14f060f70c0c6e5346a0f120c196f6718b060cd4 /CMakeLists.txt
parenta8958769ea5583d58ae51931d8b1271c23fd20ea (diff)
downloadllvm-ee03c949b85036b68c261dcc27dca064ee7e525d.tar.gz
llvm-ee03c949b85036b68c261dcc27dca064ee7e525d.tar.bz2
llvm-ee03c949b85036b68c261dcc27dca064ee7e525d.tar.xz
Add basic zlib support to LLVM. This would allow to use compression/uncompression in selected LLVM tools.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@180083 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8c3038eba..d15a54b9e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,6 +124,8 @@ set(LLVM_TARGET_ARCH "host"
option(LLVM_ENABLE_THREADS "Use threads if available." ON)
+option(LLVM_ENABLE_ZLIB "Use zlib for compression/decompression if available." ON)
+
if( LLVM_TARGETS_TO_BUILD STREQUAL "all" )
set( LLVM_TARGETS_TO_BUILD ${LLVM_ALL_TARGETS} )
endif()