summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-01-01 13:22:57 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-01-01 13:31:53 +0100
commit40ab4b2b76189804cbf3f778cbe936ca9466fa2c (patch)
tree73ede68090e94c3fc7acc618d10231ec6e34d3e5 /autoconf/configure.ac
parentf9fe35dbf1b5c37d7ced0e7ea35c13de16b9e9e3 (diff)
downloadllvm-40ab4b2b76189804cbf3f778cbe936ca9466fa2c.tar.gz
llvm-40ab4b2b76189804cbf3f778cbe936ca9466fa2c.tar.bz2
llvm-40ab4b2b76189804cbf3f778cbe936ca9466fa2c.tar.xz
[Embtk] Give ability to specify default linker hash-style
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 3fe6d42009..b46fca5648 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -444,6 +444,24 @@ if test "$withval" != "Unknown" ; then
[Default FPU to use to all compiler invocations, in case of hard float.])
fi
+dnl Default hash-style to use to all linker invocations.
+AC_ARG_WITH(default-hash-style,
+ AS_HELP_STRING([--with-default-hash-style],
+ [Default hash-style to use to all linker invocations: gnu, sysv or both.]),,
+ withval="Unknown")
+
+if test "$withval" != "Unknown" ; then
+ case "$withval" in
+ gnu);;
+ sysv);;
+ both);;
+ *)
+ AC_MSG_ERROR([Invalid --with-default-hash-style. Use "sysv", "gnu" or "both"]);;
+ esac
+ AC_DEFINE_UNQUOTED(DEFAULT_TARGET_HASHSTYLE,"$withval",
+ [Default hash-style to use to all linker invocations.])
+fi
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))