summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-02-03 01:05:01 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-02-03 01:05:01 +0100
commit64885c28258736bc788c96a243bb0002d3ac55f0 (patch)
tree29531b814db2f6ff99d5bac5f7078f00703d77e1 /autoconf/configure.ac
parentfe8ff3f35b187383a0f59697c637336aba563a4b (diff)
downloadllvm-64885c28258736bc788c96a243bb0002d3ac55f0.tar.gz
llvm-64885c28258736bc788c96a243bb0002d3ac55f0.tar.bz2
llvm-64885c28258736bc788c96a243bb0002d3ac55f0.tar.xz
[Embtk]: MIPS: give ability to specify default -mabiembtk-support-release-3.2
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 709fbb5ba3..58c54d3720 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -422,6 +422,17 @@ if test "$with_default_cpu" != "Unknown" ; then
[Default cpu (-mcpu=cpu) to use to all compiler invocations.])
fi
+dnl Default cpu (-mabi=abi) to use to all compiler invocations
+AC_ARG_WITH(default-abi,
+ AS_HELP_STRING([--with-default-abi],
+ [Add by default -mabi=abi to all compiler invocations.]),,
+ with_default_abi="Unknown")
+
+if test "$with_default_abi" != "Unknown" ; then
+ AC_DEFINE_UNQUOTED(DEFAULT_TARGET_ABI,"$with_default_abi",
+ [Default abi (-mabi=abi) to use to all compiler invocations.])
+fi
+
dnl Default float abi to use to all compiler invocations
AC_ARG_WITH(default-float,
AS_HELP_STRING([--with-default-float],