summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorDylan Noblesmith <nobled@dreamwidth.org>2012-02-04 03:00:50 +0000
committerDylan Noblesmith <nobled@dreamwidth.org>2012-02-04 03:00:50 +0000
commit965a166eb7423e201b37ddf38ef0f411464e331b (patch)
tree026e4721cdbc43259246da268a924229ef0c4e94 /autoconf/configure.ac
parent061efcfb3e79899493d857f49e50d09f29037e0a (diff)
downloadllvm-965a166eb7423e201b37ddf38ef0f411464e331b.tar.gz
llvm-965a166eb7423e201b37ddf38ef0f411464e331b.tar.bz2
llvm-965a166eb7423e201b37ddf38ef0f411464e331b.tar.xz
autoconf: put generated clang files in build dir
It was writing generated files to the clang srcdir when '--with-clang-srcdir' was specified. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@149756 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 96bb990049..0691f1fd4d 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -1574,8 +1574,11 @@ if test "${clang_src_root}" = ""; then
clang_src_root="$srcdir/tools/clang"
fi
if test -f ${clang_src_root}/README.txt; then
- AC_CONFIG_HEADERS([${clang_src_root}/include/clang/Config/config.h])
- AC_CONFIG_FILES([${clang_src_root}/docs/doxygen.cfg])
+ dnl Use variables to stay under 80 columns.
+ configh="include/clang/Config/config.h"
+ doxy="docs/doxygen.cfg"
+ AC_CONFIG_HEADERS([tools/clang/${configh}:${clang_src_root}/${configh}.in])
+ AC_CONFIG_FILES([tools/clang/${doxy}:${clang_src_root}/${doxy}.in])
fi
dnl OCaml findlib META file