summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorDanil Malyshev <dmalyshev@accesssoftek.com>2012-05-17 21:07:47 +0000
committerDanil Malyshev <dmalyshev@accesssoftek.com>2012-05-17 21:07:47 +0000
commitbb8cef51dfe7bb59109786a0ca46ad165c39aa38 (patch)
tree47107748cff082496775ef833af69b4cc385cc19 /autoconf/configure.ac
parent9133783d5483e38b16af6c10df7a8bbe655d3446 (diff)
downloadllvm-bb8cef51dfe7bb59109786a0ca46ad165c39aa38.tar.gz
llvm-bb8cef51dfe7bb59109786a0ca46ad165c39aa38.tar.bz2
llvm-bb8cef51dfe7bb59109786a0ca46ad165c39aa38.tar.xz
- Added ExecutionEngine/MCJIT tests
- Added HOST_ARCH to Makefile.config.in The HOST_ARCH will be used by MCJIT tests filter, because MCJIT supported only x86 and ARM architectures now. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@157015 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 0f488ab599..62c01f9315 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -388,6 +388,31 @@ esac
dnl Define a substitution, ARCH, for the target architecture
AC_SUBST(ARCH,$llvm_cv_target_arch)
+dnl Determine what our host architecture.
+dnl This will allow MCJIT regress tests runs only for supported
+dnl platforms.
+case $host in
+ i?86-*) host_arch="x86" ;;
+ amd64-* | x86_64-*) host_arch="x86_64" ;;
+ sparc*-*) host_arch="Sparc" ;;
+ powerpc*-*) host_arch="PowerPC" ;;
+ arm*-*) host_arch="ARM" ;;
+ mips-*) host_arch="Mips" ;;
+ mipsel-*) host_arch="Mips" ;;
+ xcore-*) host_arch="XCore" ;;
+ msp430-*) host_arch="MSP430" ;;
+ hexagon-*) host_arch="Hexagon" ;;
+ mblaze-*) host_arch="MBlaze" ;;
+ ptx-*) host_arch="PTX" ;;
+ *) host_arch="Unknown" ;;
+esac
+
+if test "$host_arch" = "Unknown" ; then
+ AC_MSG_WARN([Configuring LLVM for an unknown host archicture])
+fi
+
+AC_SUBST(HOST_ARCH,$host_arch)
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))