summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-12-31 14:17:55 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-12-31 14:17:55 +0100
commitef6eda0641204bb9dd1b0604234116e91908195f (patch)
tree538f306b369e964642a6ebe02422f92ecd462221 /autoconf/configure.ac
parent2dfd743d0243454628ff173fbf64165f435e2690 (diff)
downloadllvm-ef6eda0641204bb9dd1b0604234116e91908195f.tar.gz
llvm-ef6eda0641204bb9dd1b0604234116e91908195f.tar.bz2
llvm-ef6eda0641204bb9dd1b0604234116e91908195f.tar.xz
[Embtk] give ability to specify default FPU to use
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 3756c4f9ce..3fe6d42009 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -433,6 +433,17 @@ if test "$withval" != "Unknown" ; then
[Default float abi to use to all compiler invocations.])
fi
+dnl Default FPU to use to all compiler invocations, in case of hard float
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-fpu],
+ [Default FPU to use to all compiler invocations, in case of hard float.]),,
+ withval="Unknown")
+
+if test "$withval" != "Unknown" ; then
+ AC_DEFINE_UNQUOTED(DEFAULT_TARGET_FPU,"$withval",
+ [Default FPU to use to all compiler invocations, in case of hard float.])
+fi
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))