summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorDylan Noblesmith <nobled@dreamwidth.org>2012-02-04 02:41:36 +0000
committerDylan Noblesmith <nobled@dreamwidth.org>2012-02-04 02:41:36 +0000
commit3e82b4ad2a006c29da96a28c1b91c9b816503290 (patch)
treed0cd1dfe93165d0a7e44c9cdafd41e9f948df7fc /autoconf/configure.ac
parent9e11eb1ddb2988d0a751fdcfe433bc816c83f1f2 (diff)
downloadllvm-3e82b4ad2a006c29da96a28c1b91c9b816503290.tar.gz
llvm-3e82b4ad2a006c29da96a28c1b91c9b816503290.tar.bz2
llvm-3e82b4ad2a006c29da96a28c1b91c9b816503290.tar.xz
autoconf: fix clang detection
Now this works with and without --with-clang-srcdir, with and without an out-of-tree build. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@149749 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index f6d6d9f36d..96bb990049 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -1570,7 +1570,7 @@ dnl Configure doxygen's configuration file
AC_CONFIG_FILES([docs/doxygen.cfg])
dnl Configure clang, if present
-if test ${clang_src_root} = ""; then
+if test "${clang_src_root}" = ""; then
clang_src_root="$srcdir/tools/clang"
fi
if test -f ${clang_src_root}/README.txt; then