summaryrefslogtreecommitdiff
path: root/lib/Analysis/CMakeLists.txt
diff options
context:
space:
mode:
authorNadav Rotem <nrotem@apple.com>2012-11-02 21:48:17 +0000
committerNadav Rotem <nrotem@apple.com>2012-11-02 21:48:17 +0000
commit6bed58ef240b1e1a1fb41fb867a8ba6e7566e0e9 (patch)
treec071ea892cf774a5eda005215095242eee48fd69 /lib/Analysis/CMakeLists.txt
parent2b0c96f71ff1f26617dd805cafa35bf9a29c5a60 (diff)
downloadllvm-6bed58ef240b1e1a1fb41fb867a8ba6e7566e0e9.tar.gz
llvm-6bed58ef240b1e1a1fb41fb867a8ba6e7566e0e9.tar.bz2
llvm-6bed58ef240b1e1a1fb41fb867a8ba6e7566e0e9.tar.xz
Add a cost model analysis that allows us to estimate the cost of IR-level instructions.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@167324 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Analysis/CMakeLists.txt')
-rw-r--r--lib/Analysis/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Analysis/CMakeLists.txt b/lib/Analysis/CMakeLists.txt
index 8f5a2f2893..b3a40bee42 100644
--- a/lib/Analysis/CMakeLists.txt
+++ b/lib/Analysis/CMakeLists.txt
@@ -10,6 +10,7 @@ add_llvm_library(LLVMAnalysis
BranchProbabilityInfo.cpp
CFGPrinter.cpp
CaptureTracking.cpp
+ CostModel.cpp
CodeMetrics.cpp
ConstantFolding.cpp
DbgInfoPrinter.cpp