summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2011-04-02 06:03:35 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2011-04-02 06:03:35 +0000
commit5907d863659eb972ebb2afe07bc863a4c616f0ef (patch)
tree36571ce2f0dac41150c44d8a04b2f8199a744858 /lib/CodeGen/CMakeLists.txt
parenta122eaaee22750c4f92c33672e149eb2f0c538cb (diff)
downloadllvm-5907d863659eb972ebb2afe07bc863a4c616f0ef.tar.gz
llvm-5907d863659eb972ebb2afe07bc863a4c616f0ef.tar.bz2
llvm-5907d863659eb972ebb2afe07bc863a4c616f0ef.tar.xz
Add an InterferenceCache class for caching per-block interference ranges.
When the greedy register allocator is splitting multiple global live ranges, it tends to look at the same interference data many times. The InterferenceCache class caches queries for unaltered LiveIntervalUnions. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@128764 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index d7d0e1b381..2ca3859caf 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -19,6 +19,7 @@ add_llvm_library(LLVMCodeGen
GCStrategy.cpp
IfConversion.cpp
InlineSpiller.cpp
+ InterferenceCache.cpp
IntrinsicLowering.cpp
LLVMTargetMachine.cpp
LatencyPriorityQueue.cpp