summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2011-01-04 21:10:05 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2011-01-04 21:10:05 +0000
commit8dd070edc2209ecfdae49780ec1596b349e2cbd1 (patch)
tree2ae840c3acf41abf111447984f0f8232f8bb5e62 /lib/CodeGen/CMakeLists.txt
parent1e08cd1eaef8acbcfaf7db48d859a29583c29897 (diff)
downloadllvm-8dd070edc2209ecfdae49780ec1596b349e2cbd1.tar.gz
llvm-8dd070edc2209ecfdae49780ec1596b349e2cbd1.tar.bz2
llvm-8dd070edc2209ecfdae49780ec1596b349e2cbd1.tar.xz
Turn the EdgeBundles class into a stand-alone machine CFG analysis pass.
The analysis will be needed by both the greedy register allocator and the X86FloatingPoint pass. It only needs to be computed once when the CFG doesn't change. This pass is very fast, usually showing up as 0.0% wall time. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@122832 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index a43a0c5d53..b4da151a3a 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -10,6 +10,7 @@ add_llvm_library(LLVMCodeGen
CriticalAntiDepBreaker.cpp
DeadMachineInstructionElim.cpp
DwarfEHPrepare.cpp
+ EdgeBundles.cpp
ELFCodeEmitter.cpp
ELFWriter.cpp
ExpandISelPseudos.cpp