summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorDevang Patel <dpatel@apple.com>2011-08-10 19:04:06 +0000
committerDevang Patel <dpatel@apple.com>2011-08-10 19:04:06 +0000
commit103b8e653c981fe916b855f1b96cb35e01c4543e (patch)
tree90c56e167b6f3321ab10db347ad157af4383d534 /lib/CodeGen/CMakeLists.txt
parent8533ebad6f6e407215497ca50771f323058f5576 (diff)
downloadllvm-103b8e653c981fe916b855f1b96cb35e01c4543e.tar.gz
llvm-103b8e653c981fe916b855f1b96cb35e01c4543e.tar.bz2
llvm-103b8e653c981fe916b855f1b96cb35e01c4543e.tar.xz
Provide utility to extract and use lexical scoping information from machine instructions.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@137237 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 9cbb25cebe..af0f7f530c 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -23,6 +23,7 @@ add_llvm_library(LLVMCodeGen
IntrinsicLowering.cpp
LLVMTargetMachine.cpp
LatencyPriorityQueue.cpp
+ LexicalScopes.cpp
LiveDebugVariables.cpp
LiveInterval.cpp
LiveIntervalAnalysis.cpp