summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Stellard <thomas.stellard@amd.com>2012-09-17 14:08:37 +0000
committerTom Stellard <thomas.stellard@amd.com>2012-09-17 14:08:37 +0000
commita52c3acc14062a7c2220cedb9f75531bf730eda8 (patch)
tree7b850395aa1bc0c80f36e5022e9748da2401106f /lib/CodeGen/CMakeLists.txt
parent9b7ca410621f6988b2d4203b90058dd4252848a8 (diff)
downloadllvm-a52c3acc14062a7c2220cedb9f75531bf730eda8.tar.gz
llvm-a52c3acc14062a7c2220cedb9f75531bf730eda8.tar.bz2
llvm-a52c3acc14062a7c2220cedb9f75531bf730eda8.tar.xz
Add a MachinePostDominator pass
This is used in the AMDIL and R600 backends. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@164029 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 96c82c0669..fa6d4e16cf 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -45,6 +45,7 @@ add_llvm_library(LLVMCodeGen
MachineCopyPropagation.cpp
MachineCSE.cpp
MachineDominators.cpp
+ MachinePostDominators.cpp
MachineFunction.cpp
MachineFunctionAnalysis.cpp
MachineFunctionPass.cpp