summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorNadav Rotem <nrotem@apple.com>2012-09-06 09:17:37 +0000
committerNadav Rotem <nrotem@apple.com>2012-09-06 09:17:37 +0000
commitc05d30601ced172b55be81bb529df6be91d6ae15 (patch)
tree4d0557ea0f15a6136fdfef2f93ec4abcaad662fd /lib/CodeGen/CMakeLists.txt
parent6c822eea47dbef96940819b1ea085fabc49a1e71 (diff)
downloadllvm-c05d30601ced172b55be81bb529df6be91d6ae15.tar.gz
llvm-c05d30601ced172b55be81bb529df6be91d6ae15.tar.bz2
llvm-c05d30601ced172b55be81bb529df6be91d6ae15.tar.xz
Add a new optimization pass: Stack Coloring, that merges disjoint static allocations (allocas). Allocas are known to be
disjoint if they are marked by disjoint lifetime markers (@llvm.lifetime.XXX intrinsics). git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@163299 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 2e189ad7e7..386509b702 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -95,6 +95,7 @@ add_llvm_library(LLVMCodeGen
SplitKit.cpp
StackProtector.cpp
StackSlotColoring.cpp
+ StackColoring.cpp
StrongPHIElimination.cpp
TailDuplication.cpp
TargetFrameLoweringImpl.cpp