summaryrefslogtreecommitdiff
path: root/lib/CodeGen/SelectionDAG/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Gohman <gohman@apple.com>2008-11-19 23:18:57 +0000
committerDan Gohman <gohman@apple.com>2008-11-19 23:18:57 +0000
commit343f0c046702831a4a6aec951b6a297a23241a55 (patch)
tree2f3b2796fd768abcb439099629af7cf407a61693 /lib/CodeGen/SelectionDAG/CMakeLists.txt
parent7d1cd3f21d68179f4ebf4ee18fb7a0ddca9c5a37 (diff)
downloadllvm-343f0c046702831a4a6aec951b6a297a23241a55.tar.gz
llvm-343f0c046702831a4a6aec951b6a297a23241a55.tar.bz2
llvm-343f0c046702831a4a6aec951b6a297a23241a55.tar.xz
Experimental post-pass scheduling support. Post-pass scheduling
is currently off by default, and can be enabled with -disable-post-RA-scheduler=false. This doesn't have a significant impact on most code yet because it doesn't yet do anything to address anti-dependencies and it doesn't attempt to disambiguate memory references. Also, several popular targets don't have pipeline descriptions yet. The majority of the changes here are splitting the SelectionDAG-specific code out of ScheduleDAG, so that ScheduleDAG can be moved to libLLVMCodeGen.a. The interface between ScheduleDAG-using code and the rest of the scheduling code is somewhat rough and will evolve. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@59676 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/SelectionDAG/CMakeLists.txt')
-rw-r--r--lib/CodeGen/SelectionDAG/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/CodeGen/SelectionDAG/CMakeLists.txt b/lib/CodeGen/SelectionDAG/CMakeLists.txt
index a3654c2473..186e3d13c9 100644
--- a/lib/CodeGen/SelectionDAG/CMakeLists.txt
+++ b/lib/CodeGen/SelectionDAG/CMakeLists.txt
@@ -2,15 +2,14 @@ add_llvm_library(LLVMSelectionDAG
CallingConvLower.cpp
DAGCombiner.cpp
FastISel.cpp
- LatencyPriorityQueue.cpp
LegalizeDAG.cpp
LegalizeFloatTypes.cpp
LegalizeIntegerTypes.cpp
LegalizeTypes.cpp
LegalizeTypesGeneric.cpp
LegalizeVectorTypes.cpp
- ScheduleDAG.cpp
- ScheduleDAGEmit.cpp
+ ScheduleDAGSDNodes.cpp
+ ScheduleDAGSDNodesEmit.cpp
ScheduleDAGFast.cpp
ScheduleDAGList.cpp
ScheduleDAGRRList.cpp