summaryrefslogtreecommitdiff
path: root/lib/CodeGen/SelectionDAG/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-13 23:59:48 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-13 23:59:48 +0000
commit3a210e2d302758101ac06946e86027b327c7d0f3 (patch)
treee12390ee573b3d34a2b48b5aadfcb52d2b46296a /lib/CodeGen/SelectionDAG/CMakeLists.txt
parentbd916c54b7989ddbab373c61eb1ed2556ca44d27 (diff)
downloadllvm-3a210e2d302758101ac06946e86027b327c7d0f3.tar.gz
llvm-3a210e2d302758101ac06946e86027b327c7d0f3.tar.bz2
llvm-3a210e2d302758101ac06946e86027b327c7d0f3.tar.xz
Revert "CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally."
This reverts commit r113632 Conflicts: cmake/modules/AddLLVM.cmake git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@113819 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/SelectionDAG/CMakeLists.txt')
-rw-r--r--lib/CodeGen/SelectionDAG/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/lib/CodeGen/SelectionDAG/CMakeLists.txt b/lib/CodeGen/SelectionDAG/CMakeLists.txt
index ce3259a7f3..799988a4c8 100644
--- a/lib/CodeGen/SelectionDAG/CMakeLists.txt
+++ b/lib/CodeGen/SelectionDAG/CMakeLists.txt
@@ -22,10 +22,4 @@ add_llvm_library(LLVMSelectionDAG
TargetSelectionDAGInfo.cpp
)
-target_link_libraries(LLVMSelectionDAG
- LLVMAnalysis
- LLVMCodeGen
- LLVMCore
- LLVMMC
- LLVMTarget
- )
+target_link_libraries (LLVMSelectionDAG LLVMAnalysis LLVMAsmPrinter LLVMCodeGen)