summaryrefslogtreecommitdiff
path: root/lib/CodeGen/SelectionDAG/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-10 21:14:25 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-10 21:14:25 +0000
commit4e9c939312ff73bd0c6a6485fd5f97012f5910fa (patch)
tree5ac7e42fde2303030a9af1183b7842986459bc45 /lib/CodeGen/SelectionDAG/CMakeLists.txt
parentbb811a244567aa8a1522203f15588f4d001b7353 (diff)
downloadllvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.gz
llvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.bz2
llvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.xz
CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@113632 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/SelectionDAG/CMakeLists.txt')
-rw-r--r--lib/CodeGen/SelectionDAG/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/CodeGen/SelectionDAG/CMakeLists.txt b/lib/CodeGen/SelectionDAG/CMakeLists.txt
index 799988a4c8..ce3259a7f3 100644
--- a/lib/CodeGen/SelectionDAG/CMakeLists.txt
+++ b/lib/CodeGen/SelectionDAG/CMakeLists.txt
@@ -22,4 +22,10 @@ add_llvm_library(LLVMSelectionDAG
TargetSelectionDAGInfo.cpp
)
-target_link_libraries (LLVMSelectionDAG LLVMAnalysis LLVMAsmPrinter LLVMCodeGen)
+target_link_libraries(LLVMSelectionDAG
+ LLVMAnalysis
+ LLVMCodeGen
+ LLVMCore
+ LLVMMC
+ LLVMTarget
+ )