summaryrefslogtreecommitdiff
path: root/lib/CodeGen/SelectionDAG/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Gohman <gohman@apple.com>2008-11-15 00:23:40 +0000
committerDan Gohman <gohman@apple.com>2008-11-15 00:23:40 +0000
commitade9f1893412184c164aa3eb55a3e007ec647303 (patch)
treef175accbfd13585c03ea5701acdc7debc1cf1d42 /lib/CodeGen/SelectionDAG/CMakeLists.txt
parent2833f59cad691e9679f6c5946fa630f1bef5b89a (diff)
downloadllvm-ade9f1893412184c164aa3eb55a3e007ec647303.tar.gz
llvm-ade9f1893412184c164aa3eb55a3e007ec647303.tar.bz2
llvm-ade9f1893412184c164aa3eb55a3e007ec647303.tar.xz
Move ScheduleDAGList's LatencyPriorityQueue class out to a separate file.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@59340 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/SelectionDAG/CMakeLists.txt')
-rw-r--r--lib/CodeGen/SelectionDAG/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/SelectionDAG/CMakeLists.txt b/lib/CodeGen/SelectionDAG/CMakeLists.txt
index dad932bf37..a3654c2473 100644
--- a/lib/CodeGen/SelectionDAG/CMakeLists.txt
+++ b/lib/CodeGen/SelectionDAG/CMakeLists.txt
@@ -2,6 +2,7 @@ add_llvm_library(LLVMSelectionDAG
CallingConvLower.cpp
DAGCombiner.cpp
FastISel.cpp
+ LatencyPriorityQueue.cpp
LegalizeDAG.cpp
LegalizeFloatTypes.cpp
LegalizeIntegerTypes.cpp