summaryrefslogtreecommitdiff
path: root/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
diff options
context:
space:
mode:
authorPreston Gurd <preston.gurd@intel.com>2012-04-16 22:12:58 +0000
committerPreston Gurd <preston.gurd@intel.com>2012-04-16 22:12:58 +0000
commit689ff9c00f4f3dcf3491778bcdbda79e19e2285d (patch)
tree5b27bacb0f581a45e9274eb9894e0fd4bb259bf8 /lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
parentf1a60c734c2edb97ab75e67328935538fae5bae6 (diff)
downloadllvm-689ff9c00f4f3dcf3491778bcdbda79e19e2285d.tar.gz
llvm-689ff9c00f4f3dcf3491778bcdbda79e19e2285d.tar.bz2
llvm-689ff9c00f4f3dcf3491778bcdbda79e19e2285d.tar.xz
Implement GDB integration for source level debugging of code JITed using
the MCJIT execution engine. The GDB JIT debugging integration support works by registering a loaded object image with a pre-defined function that GDB will monitor if GDB is attached. GDB integration support is implemented for ELF only at this time. This integration requires GDB version 7.0 or newer. Patch by Andy Kaylor! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@154868 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt b/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
index 002e63cd3b..cbf7cf14d4 100644
--- a/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
+++ b/lib/ExecutionEngine/RuntimeDyld/CMakeLists.txt
@@ -1,5 +1,6 @@
add_llvm_library(LLVMRuntimeDyld
+ GDBRegistrar.cpp
RuntimeDyld.cpp
- RuntimeDyldMachO.cpp
RuntimeDyldELF.cpp
+ RuntimeDyldMachO.cpp
)