summaryrefslogtreecommitdiff
path: root/lib/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2013-11-09 12:26:54 +0000
committerChandler Carruth <chandlerc@gmail.com>2013-11-09 12:26:54 +0000
commit49837ef8111fbeace7ae6379ca733c8f8fa94cfe (patch)
tree56766bbd9f25967c8c32bb5b735161305ea215ed /lib/IR/CMakeLists.txt
parent9defe9a7ccb29b02ed78bede5892fd4e3e64307b (diff)
downloadllvm-49837ef8111fbeace7ae6379ca733c8f8fa94cfe.tar.gz
llvm-49837ef8111fbeace7ae6379ca733c8f8fa94cfe.tar.bz2
llvm-49837ef8111fbeace7ae6379ca733c8f8fa94cfe.tar.xz
Move the old pass manager infrastructure into a legacy namespace and
give the files a legacy prefix in the right directory. Use forwarding headers in the old locations to paper over the name change for most clients during the transitional period. No functionality changed here! This is just clearing some space to reduce renaming churn later on with a new system. Even when the new stuff starts to go in, it is going to be hidden behind a flag and off-by-default as it is still WIP and under development. This patch is specifically designed so that very little out-of-tree code has to change. I'm going to work as hard as I can to keep that the case. Only direct forward declarations of the PassManager class are impacted by this change. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@194324 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/IR/CMakeLists.txt')
-rw-r--r--lib/IR/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/IR/CMakeLists.txt b/lib/IR/CMakeLists.txt
index c2a4ee3aae..2ad5fdb25b 100644
--- a/lib/IR/CMakeLists.txt
+++ b/lib/IR/CMakeLists.txt
@@ -6,10 +6,10 @@ add_llvm_library(LLVMCore
ConstantFold.cpp
Constants.cpp
Core.cpp
+ DIBuilder.cpp
DataLayout.cpp
DebugInfo.cpp
DebugLoc.cpp
- DIBuilder.cpp
Dominators.cpp
Function.cpp
GCOV.cpp
@@ -23,10 +23,10 @@ add_llvm_library(LLVMCore
LLVMContext.cpp
LLVMContextImpl.cpp
LeakDetector.cpp
+ LegacyPassManager.cpp
Metadata.cpp
Module.cpp
Pass.cpp
- PassManager.cpp
PassRegistry.cpp
PrintModulePass.cpp
Type.cpp