summaryrefslogtreecommitdiff
path: root/lib/Object/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2011-06-13 11:12:12 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2011-06-13 11:12:12 +0000
commitfc9ec691da995e7894490a80f5b6b65daf5e34d3 (patch)
tree717bb23e6e1af2314d66495c62843a8a8725a5f1 /lib/Object/CMakeLists.txt
parentbf58996c086fe4993ae778adb838d230ced06068 (diff)
downloadllvm-fc9ec691da995e7894490a80f5b6b65daf5e34d3.tar.gz
llvm-fc9ec691da995e7894490a80f5b6b65daf5e34d3.tar.bz2
llvm-fc9ec691da995e7894490a80f5b6b65daf5e34d3.tar.xz
Add Binary class. This is a cleaner parent than ObjectFile.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@132910 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Object/CMakeLists.txt')
-rw-r--r--lib/Object/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Object/CMakeLists.txt b/lib/Object/CMakeLists.txt
index e32940e2de..68e5e94924 100644
--- a/lib/Object/CMakeLists.txt
+++ b/lib/Object/CMakeLists.txt
@@ -1,4 +1,5 @@
add_llvm_library(LLVMObject
+ Binary.cpp
COFFObjectFile.cpp
ELFObjectFile.cpp
Error.cpp