summaryrefslogtreecommitdiff
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-10-17 02:26:16 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-10-17 02:26:16 +0000
commitf0c55a9b9797855a4c488c7a6a97d336a5bafd8e (patch)
tree6e4ef374b23b14db2199b461e21322b316061515 /lib/Support/CMakeLists.txt
parentd56d61af0190ee8024eb71dd4138ed7861f20adc (diff)
downloadllvm-f0c55a9b9797855a4c488c7a6a97d336a5bafd8e.tar.gz
llvm-f0c55a9b9797855a4c488c7a6a97d336a5bafd8e.tar.bz2
llvm-f0c55a9b9797855a4c488c7a6a97d336a5bafd8e.tar.xz
Build with RTTI and exceptions disabled. Only in GCC for now.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116682 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
index f7e02c9bc0..c9c862ce84 100644
--- a/lib/Support/CMakeLists.txt
+++ b/lib/Support/CMakeLists.txt
@@ -1,3 +1,6 @@
+## FIXME: This only requires RTTI because tblgen uses it. Fix that.
+set(LLVM_REQUIRES_RTTI 1)
+
add_llvm_library(LLVMSupport
APFloat.cpp
APInt.cpp