summaryrefslogtreecommitdiff
path: root/lib/TableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorChe-Liang Chiou <clchiou@gmail.com>2011-10-04 15:14:51 +0000
committerChe-Liang Chiou <clchiou@gmail.com>2011-10-04 15:14:51 +0000
commitf98742565765a10558824ea45f0d9a70843ed0d9 (patch)
tree88c769a0ed43e8d86df7354c4826df16f942c113 /lib/TableGen/CMakeLists.txt
parent34804c4f4793abbcb908c79fe9512c03090d8520 (diff)
downloadllvm-f98742565765a10558824ea45f0d9a70843ed0d9.tar.gz
llvm-f98742565765a10558824ea45f0d9a70843ed0d9.tar.bz2
llvm-f98742565765a10558824ea45f0d9a70843ed0d9.tar.xz
tblgen: add preprocessor as a separate mode
This patch adds a preprocessor that can expand nested for-loops for saving some copy-n-paste in *.td files. The preprocessor is not yet integrated with TGParser, and so it has no direct effect on *.td inputs. However, you may preprocess an td input (and only preprocess it). To test the proprecessor, type: tblgen -E -o $@ $< git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@141079 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/TableGen/CMakeLists.txt')
-rw-r--r--lib/TableGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/TableGen/CMakeLists.txt b/lib/TableGen/CMakeLists.txt
index 0db4134691..507c915ae6 100644
--- a/lib/TableGen/CMakeLists.txt
+++ b/lib/TableGen/CMakeLists.txt
@@ -9,6 +9,7 @@ add_llvm_library(LLVMTableGen
TableGenBackend.cpp
TGLexer.cpp
TGParser.cpp
+ TGPreprocessor.cpp
)
add_llvm_library_dependencies(LLVMTableGen