summaryrefslogtreecommitdiff
path: root/lib/Target/ARM/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-09-28 11:48:19 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-09-28 11:48:19 +0000
commit38e1390c29c024d5bbff3063c2a86bceb7bd3e60 (patch)
tree2a1302871c06da26387577afbb45cc716ed3108b /lib/Target/ARM/CMakeLists.txt
parentacf1d482bff0eb8e9a3562a1f53033a53baf3727 (diff)
downloadllvm-38e1390c29c024d5bbff3063c2a86bceb7bd3e60.tar.gz
llvm-38e1390c29c024d5bbff3063c2a86bceb7bd3e60.tar.bz2
llvm-38e1390c29c024d5bbff3063c2a86bceb7bd3e60.tar.xz
Add ARM Disassembler to the CMake build.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@114949 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/ARM/CMakeLists.txt')
-rw-r--r--lib/Target/ARM/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/ARM/CMakeLists.txt b/lib/Target/ARM/CMakeLists.txt
index 0b48845649..8bd0c06507 100644
--- a/lib/Target/ARM/CMakeLists.txt
+++ b/lib/Target/ARM/CMakeLists.txt
@@ -13,6 +13,7 @@ tablegen(ARMGenFastISel.inc -gen-fast-isel)
tablegen(ARMGenCallingConv.inc -gen-callingconv)
tablegen(ARMGenSubtarget.inc -gen-subtarget)
tablegen(ARMGenEDInfo.inc -gen-enhanced-disassembly-info)
+tablegen(ARMGenDecoderTables.inc -gen-arm-decoder)
add_llvm_target(ARMCodeGen
ARMAsmPrinter.cpp