summaryrefslogtreecommitdiff
path: root/lib/Target/ARM/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Cheng <evan.cheng@apple.com>2011-01-13 07:58:56 +0000
committerEvan Cheng <evan.cheng@apple.com>2011-01-13 07:58:56 +0000
commit7597212abced110723f2fee985a7d60557c092ec (patch)
tree5e01be3847a6ec23112b8feb910ac5a2bb6b2fcb /lib/Target/ARM/CMakeLists.txt
parent04f5079ca1fd6c46a2b2efc369e293fb6feab793 (diff)
downloadllvm-7597212abced110723f2fee985a7d60557c092ec.tar.gz
llvm-7597212abced110723f2fee985a7d60557c092ec.tar.bz2
llvm-7597212abced110723f2fee985a7d60557c092ec.tar.xz
Model :upper16: and :lower16: as ARM specific MCTargetExpr. This is a step
in the right direction. It eliminated some hacks and will unblock codegen work. But it's far from being done. It doesn't reject illegal expressions, e.g. (FOO - :lower16:BAR). It also doesn't work in Thumb2 mode at all. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@123369 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/ARM/CMakeLists.txt')
-rw-r--r--lib/Target/ARM/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/ARM/CMakeLists.txt b/lib/Target/ARM/CMakeLists.txt
index cd376e72a9..38741eb26f 100644
--- a/lib/Target/ARM/CMakeLists.txt
+++ b/lib/Target/ARM/CMakeLists.txt
@@ -35,6 +35,7 @@ add_llvm_target(ARMCodeGen
ARMInstrInfo.cpp
ARMJITInfo.cpp
ARMMCCodeEmitter.cpp
+ ARMMCExpr.cpp
ARMLoadStoreOptimizer.cpp
ARMMCAsmInfo.cpp
ARMMCInstLower.cpp