summaryrefslogtreecommitdiff
path: root/lib/Target/ARM/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-10-14 15:54:46 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-10-14 15:54:46 +0000
commit7bd698153db1403cbe8cc7cd8a250d4cd815d603 (patch)
treee4fff34bf986f0d1670c68de1df542d0376056f5 /lib/Target/ARM/CMakeLists.txt
parent00a9618458d998688ae5846d44b17685ddeccc39 (diff)
downloadllvm-7bd698153db1403cbe8cc7cd8a250d4cd815d603.tar.gz
llvm-7bd698153db1403cbe8cc7cd8a250d4cd815d603.tar.bz2
llvm-7bd698153db1403cbe8cc7cd8a250d4cd815d603.tar.xz
Remove explicit dependency of LLVMARMCodeGen on LLVMARMAsmPrinter. It
creates a cyclic dependency that breaks the build when BUILD_SHARED_LIBS=ON git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116480 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/ARM/CMakeLists.txt')
-rw-r--r--lib/Target/ARM/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/lib/Target/ARM/CMakeLists.txt b/lib/Target/ARM/CMakeLists.txt
index 31c80674df..16d127e552 100644
--- a/lib/Target/ARM/CMakeLists.txt
+++ b/lib/Target/ARM/CMakeLists.txt
@@ -49,8 +49,3 @@ add_llvm_target(ARMCodeGen
Thumb2RegisterInfo.cpp
Thumb2SizeReduction.cpp
)
-
-# The ARM CodeGen library depends on the AsmPrinter for just a
-# vtable, but GenLibDeps.pl is unable to detect it. So without this,
-# the build fails with "undefined reference to `vtable for ..."
-target_link_libraries(LLVMARMCodeGen LLVMARMAsmPrinter)