summaryrefslogtreecommitdiff
path: root/lib/Target/ARM/CMakeLists.txt
diff options
context:
space:
mode:
authorJason W Kim <jason.w.kim.2009@gmail.com>2010-09-30 02:17:26 +0000
committerJason W Kim <jason.w.kim.2009@gmail.com>2010-09-30 02:17:26 +0000
commitd4d4f4f488d46a9743a0c494b42b22a1b15e0e7d (patch)
treebabfdaf1a18ef75d89bc4fe0b066d1f521fcd2c0 /lib/Target/ARM/CMakeLists.txt
parenta4e97de71d7dd890eb9f705710bd094f0fa7ac49 (diff)
downloadllvm-d4d4f4f488d46a9743a0c494b42b22a1b15e0e7d.tar.gz
llvm-d4d4f4f488d46a9743a0c494b42b22a1b15e0e7d.tar.bz2
llvm-d4d4f4f488d46a9743a0c494b42b22a1b15e0e7d.tar.xz
I added a new file ARMAsmBackend which stubs out in similar ways to
the eqv X86 class. For now, I split the ELFARMAsmBackend from the DarwinARMAsmBackend (also mimicking X86) Tested against -r115126 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@115129 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/ARM/CMakeLists.txt')
-rw-r--r--lib/Target/ARM/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/ARM/CMakeLists.txt b/lib/Target/ARM/CMakeLists.txt
index 49120588e3..3cf58e162c 100644
--- a/lib/Target/ARM/CMakeLists.txt
+++ b/lib/Target/ARM/CMakeLists.txt
@@ -16,6 +16,7 @@ tablegen(ARMGenEDInfo.inc -gen-enhanced-disassembly-info)
tablegen(ARMGenDecoderTables.inc -gen-arm-decoder)
add_llvm_target(ARMCodeGen
+ ARMAsmBackend.cpp
ARMAsmPrinter.cpp
ARMBaseInstrInfo.cpp
ARMBaseRegisterInfo.cpp