summaryrefslogtreecommitdiff
path: root/lib/Target/ARM/Disassembler/CMakeLists.txt
diff options
context:
space:
mode:
authorOwen Anderson <resistor@mac.com>2011-08-09 20:55:18 +0000
committerOwen Anderson <resistor@mac.com>2011-08-09 20:55:18 +0000
commit8d7d2e1238fac58c01ccfb719d0cc5680a079561 (patch)
tree3cf4ccfcd58d5969d7e2d9307486637382cd3fff /lib/Target/ARM/Disassembler/CMakeLists.txt
parent0dc8b42987d091fafe9fc53f0159db8d0ecced4d (diff)
downloadllvm-8d7d2e1238fac58c01ccfb719d0cc5680a079561.tar.gz
llvm-8d7d2e1238fac58c01ccfb719d0cc5680a079561.tar.bz2
llvm-8d7d2e1238fac58c01ccfb719d0cc5680a079561.tar.xz
Replace the existing ARM disassembler with a new one based on the FixedLenDecoderEmitter.
This new disassembler can correctly decode all the testcases that the old one did, though some "expected failure" testcases are XFAIL'd for now because it is not (yet) as strict in operand checking as the old one was. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@137144 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/ARM/Disassembler/CMakeLists.txt')
-rw-r--r--lib/Target/ARM/Disassembler/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Target/ARM/Disassembler/CMakeLists.txt b/lib/Target/ARM/Disassembler/CMakeLists.txt
index 952dab53ec..da87751150 100644
--- a/lib/Target/ARM/Disassembler/CMakeLists.txt
+++ b/lib/Target/ARM/Disassembler/CMakeLists.txt
@@ -2,7 +2,6 @@ include_directories( ${CMAKE_CURRENT_BINARY_DIR}/.. ${CMAKE_CURRENT_SOURCE_DIR}/
add_llvm_library(LLVMARMDisassembler
ARMDisassembler.cpp
- ARMDisassemblerCore.cpp
)
# workaround for hanging compilation on MSVC8, 9 and 10
if( MSVC_VERSION EQUAL 1400 OR MSVC_VERSION EQUAL 1500 OR MSVC_VERSION EQUAL 1600 )