summaryrefslogtreecommitdiff
path: root/lib/Target/Hexagon/CMakeLists.txt
diff options
context:
space:
mode:
authorJyotsna Verma <jverma@codeaurora.org>2013-05-14 18:54:06 +0000
committerJyotsna Verma <jverma@codeaurora.org>2013-05-14 18:54:06 +0000
commita29a8965e206e689d292d7f2e42f2548770e30d3 (patch)
tree138b51a358b8faf8b5ad4c153e4e653590ace1a2 /lib/Target/Hexagon/CMakeLists.txt
parentf276c70bb8ff25e7c0ef13e9afc59623a3c135ba (diff)
downloadllvm-a29a8965e206e689d292d7f2e42f2548770e30d3.tar.gz
llvm-a29a8965e206e689d292d7f2e42f2548770e30d3.tar.bz2
llvm-a29a8965e206e689d292d7f2e42f2548770e30d3.tar.xz
Hexagon: Pass to replace tranfer/copy instructions into combine instruction
where possible. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@181817 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Hexagon/CMakeLists.txt')
-rw-r--r--lib/Target/Hexagon/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/Hexagon/CMakeLists.txt b/lib/Target/Hexagon/CMakeLists.txt
index 99d7a3a963..57044b27d6 100644
--- a/lib/Target/Hexagon/CMakeLists.txt
+++ b/lib/Target/Hexagon/CMakeLists.txt
@@ -35,6 +35,7 @@ add_llvm_target(HexagonCodeGen
HexagonTargetObjectFile.cpp
HexagonVLIWPacketizer.cpp
HexagonNewValueJump.cpp
+ HexagonCopyToCombine.cpp
)
add_subdirectory(TargetInfo)