summaryrefslogtreecommitdiff
path: root/lib/Target/Hexagon/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Christopher <echristo@apple.com>2012-02-15 18:32:25 +0000
committerEric Christopher <echristo@apple.com>2012-02-15 18:32:25 +0000
commiteddd6abdde2c66743e2bc3fe8996aa38d0e77b80 (patch)
tree262dc467d7951b0deac6ad386802720177cc6073 /lib/Target/Hexagon/CMakeLists.txt
parenta997b3e51a9739447dfdbe1ba5f7743a1f5082af (diff)
downloadllvm-eddd6abdde2c66743e2bc3fe8996aa38d0e77b80.tar.gz
llvm-eddd6abdde2c66743e2bc3fe8996aa38d0e77b80.tar.bz2
llvm-eddd6abdde2c66743e2bc3fe8996aa38d0e77b80.tar.xz
Revert "Optimize redundant sign extends and negation of predicates"
as it's breaking the build. This reverts commit 11241abca5e2a313412fed594bb9d9fa2a2057fb. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@150604 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Hexagon/CMakeLists.txt')
-rw-r--r--lib/Target/Hexagon/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Target/Hexagon/CMakeLists.txt b/lib/Target/Hexagon/CMakeLists.txt
index 06040f009f..0acc21181e 100644
--- a/lib/Target/Hexagon/CMakeLists.txt
+++ b/lib/Target/Hexagon/CMakeLists.txt
@@ -20,7 +20,7 @@ add_llvm_target(HexagonCodeGen
HexagonInstrInfo.cpp
HexagonISelDAGToDAG.cpp
HexagonISelLowering.cpp
- HexagonPeephole.cpp
+ HexagonOptimizeSZExtends.cpp
HexagonRegisterInfo.cpp
HexagonRemoveSZExtArgs.cpp
HexagonSelectionDAGInfo.cpp