summaryrefslogtreecommitdiff
path: root/lib/Target/MSP430/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Grosbach <grosbach@apple.com>2010-10-05 00:34:11 +0000
committerJim Grosbach <grosbach@apple.com>2010-10-05 00:34:11 +0000
commit33caa07cc57a6311292f7e89c008c5479bde50ca (patch)
tree343da0afdd30b62ece9fc5a0a80e64fe87ffc527 /lib/Target/MSP430/CMakeLists.txt
parent90371ad16529099d53e78b1c6ac0c7e8b6374153 (diff)
downloadllvm-33caa07cc57a6311292f7e89c008c5479bde50ca.tar.gz
llvm-33caa07cc57a6311292f7e89c008c5479bde50ca.tar.bz2
llvm-33caa07cc57a6311292f7e89c008c5479bde50ca.tar.xz
Re-apply r115363 and r115366 now that r115525 has removed the un-needed header
that caused the circular dependencies on Linux. Built OK for me on OSX and Linux (Ubuntu) with configure/make and CMake. Will keep an eye on the bots.... git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@115582 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/MSP430/CMakeLists.txt')
-rw-r--r--lib/Target/MSP430/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/Target/MSP430/CMakeLists.txt b/lib/Target/MSP430/CMakeLists.txt
index 2360ffdef4..fa223f9617 100644
--- a/lib/Target/MSP430/CMakeLists.txt
+++ b/lib/Target/MSP430/CMakeLists.txt
@@ -20,4 +20,6 @@ add_llvm_target(MSP430CodeGen
MSP430Subtarget.cpp
MSP430TargetMachine.cpp
MSP430SelectionDAGInfo.cpp
+ MSP430AsmPrinter.cpp
+ MSP430MCInstLower.cpp
)