summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2010-04-13 22:47:43 +0000
committerDouglas Gregor <dgregor@apple.com>2010-04-13 22:47:43 +0000
commit533ae9b71d88df8d1891c8c653eeb7912b25dbb0 (patch)
tree0b89e60f2551cb456e6fbc798eaa1b5635ccca91 /lib/Target/X86/CMakeLists.txt
parent6327537a377d2b77748270258e99b257bf1723df (diff)
downloadllvm-533ae9b71d88df8d1891c8c653eeb7912b25dbb0.tar.gz
llvm-533ae9b71d88df8d1891c8c653eeb7912b25dbb0.tar.bz2
llvm-533ae9b71d88df8d1891c8c653eeb7912b25dbb0.tar.xz
Unbreak CMake build by improving the EnhancedDisassembly makefile a
bit (we're not trying to build a shared library yet) and generating the X86GenEDInfo.inc and ARMGenEDInfo.inc files as necessary. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@101188 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index 22285f1932..cac32dbb0b 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -13,6 +13,7 @@ tablegen(X86GenDAGISel.inc -gen-dag-isel)
tablegen(X86GenFastISel.inc -gen-fast-isel)
tablegen(X86GenCallingConv.inc -gen-callingconv)
tablegen(X86GenSubtarget.inc -gen-subtarget)
+tablegen(X86GenEDInfo.inc -gen-enhanced-disassembly-info)
set(sources
SSEDomainFix.cpp