summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno Cardoso Lopes <bruno.cardoso@gmail.com>2011-08-23 01:14:17 +0000
committerBruno Cardoso Lopes <bruno.cardoso@gmail.com>2011-08-23 01:14:17 +0000
commit3bde6fe0df05558b89e7edfe48ac05da59beb81a (patch)
tree011a10aa34d5fb2d2afa5786803bd3f240a9d2a7 /lib/Target/X86/CMakeLists.txt
parent7e99b5c8a36e3e8d611e47122f9c596b58ccf3e8 (diff)
downloadllvm-3bde6fe0df05558b89e7edfe48ac05da59beb81a.tar.gz
llvm-3bde6fe0df05558b89e7edfe48ac05da59beb81a.tar.bz2
llvm-3bde6fe0df05558b89e7edfe48ac05da59beb81a.tar.xz
Introduce a pass to insert vzeroupper instructions to avoid AVX to
SSE transition penalty. The pass is enabled through the "x86-use-vzeroupper" llc command line option. This is only the first step (very naive and conservative one) to sketch out the idea, but proper DFA is coming next to allow smarter decisions. Comments and ideas now and in further commits will be very appreciated. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@138317 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index 1fd55128e2..c481eb9552 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -32,6 +32,7 @@ set(sources
X86Subtarget.cpp
X86TargetMachine.cpp
X86TargetObjectFile.cpp
+ X86VZeroUpper.cpp
)
if( CMAKE_CL_64 )