summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2010-07-16 17:41:44 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2010-07-16 17:41:44 +0000
commit468a2a44e2a2efb5a2cd441205fc78b80edd3844 (patch)
treea0a50ee74203c5f91a47242f5a54c171baf58610 /lib/Target/X86/CMakeLists.txt
parente098e7a96d869367f95df0dbcafa3ededce765b6 (diff)
downloadllvm-468a2a44e2a2efb5a2cd441205fc78b80edd3844.tar.gz
llvm-468a2a44e2a2efb5a2cd441205fc78b80edd3844.tar.bz2
llvm-468a2a44e2a2efb5a2cd441205fc78b80edd3844.tar.xz
Remove the X86::FP_REG_KILL pseudo-instruction and the X86FloatingPointRegKill
pass that inserted it. It is no longer necessary to limit the live ranges of FP registers to a single basic block. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@108536 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index 133482036c..938e158939 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -22,7 +22,6 @@ set(sources
X86COFFMachineModuleInfo.cpp
X86ELFWriterInfo.cpp
X86FloatingPoint.cpp
- X86FloatingPointRegKill.cpp
X86ISelDAGToDAG.cpp
X86ISelLowering.cpp
X86InstrInfo.cpp