summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorNadav Rotem <nrotem@apple.com>2013-01-05 05:42:48 +0000
committerNadav Rotem <nrotem@apple.com>2013-01-05 05:42:48 +0000
commit5d1f5c17377e56d88a525cf82d02e6e5df254580 (patch)
treea9198bd8746793423ea59187b1a108dea0852805 /lib/Target/X86/CMakeLists.txt
parent255cd6f317f3a0bad6e7939ca5ce49b33c6676f9 (diff)
downloadllvm-5d1f5c17377e56d88a525cf82d02e6e5df254580.tar.gz
llvm-5d1f5c17377e56d88a525cf82d02e6e5df254580.tar.bz2
llvm-5d1f5c17377e56d88a525cf82d02e6e5df254580.tar.xz
Revert revision 171524. Original message:
URL: http://llvm.org/viewvc/llvm-project?rev=171524&view=rev Log: The current Intel Atom microarchitecture has a feature whereby when a function returns early then it is slightly faster to execute a sequence of NOP instructions to wait until the return address is ready, as opposed to simply stalling on the ret instruction until the return address is ready. When compiling for X86 Atom only, this patch will run a pass, called "X86PadShortFunction" which will add NOP instructions where less than four cycles elapse between function entry and return. It includes tests. Patch by Andy Zhang. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@171603 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index 140c80dee4..19912cc6bc 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -25,7 +25,6 @@ set(sources
X86JITInfo.cpp
X86MCInstLower.cpp
X86MachineFunctionInfo.cpp
- X86PadShortFunction.cpp
X86RegisterInfo.cpp
X86SelectionDAGInfo.cpp
X86Subtarget.cpp