summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2009-09-20 06:45:52 +0000
committerChris Lattner <sabre@nondot.org>2009-09-20 06:45:52 +0000
commit67c6b6ee71826b2c48b4da490340e5c3e2a94cd2 (patch)
treeff3c30c78dc08eac54d5cb3842b0d2079d2a9be9 /lib/Target/X86/CMakeLists.txt
parentb13efdafec254746bc83583a10ec3604210d0d35 (diff)
downloadllvm-67c6b6ee71826b2c48b4da490340e5c3e2a94cd2.tar.gz
llvm-67c6b6ee71826b2c48b4da490340e5c3e2a94cd2.tar.bz2
llvm-67c6b6ee71826b2c48b4da490340e5c3e2a94cd2.tar.xz
split random COFF asmprinter state out to X86COFFMachineModuleInfo.h.
Make dllexport directives come out in determinstic order. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@82381 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index a6c97437a6..3ad65fbedc 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -15,6 +15,7 @@ tablegen(X86GenSubtarget.inc -gen-subtarget)
set(sources
X86CodeEmitter.cpp
+ X86COFFMachineModuleInfo.cpp
X86ELFWriterInfo.cpp
X86FloatingPoint.cpp
X86FloatingPointRegKill.cpp