summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-12-31 20:15:37 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-12-31 20:15:37 +0000
commitba6f918a6df62fcdfdaa5d880aeb971975d5284b (patch)
treec1b628dfad86e462c83b825c0a9ccdb8388b6510 /lib/Target/X86/CMakeLists.txt
parent023c63351ec78d88c1b3bd600cbcab56838769ae (diff)
downloadllvm-ba6f918a6df62fcdfdaa5d880aeb971975d5284b.tar.gz
llvm-ba6f918a6df62fcdfdaa5d880aeb971975d5284b.tar.bz2
llvm-ba6f918a6df62fcdfdaa5d880aeb971975d5284b.tar.xz
Add to the list of cmake files the object file, not the asm file. This
is necessary for executing the custom command that runs the assember. Fixes PR8877. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@122649 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index e62dfca491..036dbcda21 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -47,7 +47,7 @@ if( CMAKE_CL_64 )
MAIN_DEPENDENCY X86CompilationCallback_Win64.asm
COMMAND ${CMAKE_ASM_MASM_COMPILER} /Fo ${CMAKE_CURRENT_BINARY_DIR}/X86CompilationCallback_Win64.obj /c ${CMAKE_CURRENT_SOURCE_DIR}/X86CompilationCallback_Win64.asm
)
- set(sources ${sources} X86CompilationCallback_Win64.asm)
+ set(sources ${sources} ${CMAKE_CURRENT_BINARY_DIR}/X86CompilationCallback_Win64.obj)
endif()
add_llvm_target(X86CodeGen ${sources})